DevOps platform GitLab this week issued patches to address a critical security flaw in its software that could lead to arbitrary code execution on affected systems.

Tracked as CVE-2022-2884, the issue is rated 9.9 on the CVSS vulnerability scoring system and impacts all versions of GitLab Community Edition (CE) and Enterprise Edition (EE) starting from 11.3.4 before 15.1.5, 15.2 before 15.2.3, and 15.3 before 15.3.1.

At its core, the security weakness is a case of authenticated remote code execution that can be triggered via the GitHub import API. GitLab credited yvvdwf with discovering and reporting the flaw.


A successful exploitation of the critical flaw could enable a malicious actor to run malicious code on the target machine, inject malware and backdoors, and seize complete control of the susceptible devices.

While the issue has been resolved in versions 15.3.1, 15.2.3, 15.1.5, users also have the option of securing against the flaw by temporarily disabling the GitHub import option -

  • Click "Menu" -> "Admin"
  • Click "Settings" -> "General"
  • Expand the "Visibility and access controls" tab
  • Under "Import sources" disable the "GitHub" option
  • Click "Save changes"

There is no evidence that the issue is being exploited in in-the-wild attacks. That said, users running an affected installation are recommended to update to the latest version as soon as possible.

Found this article interesting? Follow us on Twitter and LinkedIn to read more exclusive content we post.